Latest Marlin Firmware for BigTreeTech SKR Mini E3 Board on Ender 3 and Ender 5

After scouring the internet for the “latest” marlin 2.0 bug-fix configuration that would actually allow Marlin to compile in VS Code for hours without luck, i decided to write my own configuration files. I will tell you that there are some configurations and firmware provided by BigTreeTech and other guys via Git hub; but those are older firmware versions and when pasting the config into your latest marlin 2.0 bug-fix folder it will fail to compile due to changes in code.

I am including the firmware.bin files for both printers, but if you wish to modify the firmware and make any of your own changes you will need the software. Instead of using Arduino IDE we recommend downloading VSCode from here. Once you have installed VSCode, you will need to install the plug-in Platform IO. The full guide for setting up VSCode to compile marlin can be found at the Marlin website here.

Both firmware are ready to go, all you have to do is simply copy the firmware.bin that I have copied into the root folder onto a micro SD card. Once you have copied the firmware.bin file to your micro SD card, power off the printer and insert the SD card. Next time you power the printer up, the firmware will automatically flash. It will take several seconds to complete, the screen will flash and re-activate. Once you are done flashing firmware I recommend either sending a M500/M501 via Pronterface or visit the configuration menu and choose “Store Settings” and then click “Load Settings” to reload the EEProm.

Ender 3 Firmware BigTreeTech SKR Mini E3

I currently am providing firmware for the Ender 3 with my ABL probe already setup in it. It’s the capacitive style proximity sensor probe we show on our website, and it’s using the EZABL stock probe mount for ease. You will have to change the ABL settings or disable them depending on your application, and I can post another firmware later that does not have ABL enabled. I used a difference tool to compare my configuration with BigTreeTech’s Ender configuration files, and made the necessary changes. The only things I implemented additionally are baby stepping, and increasing the max acceleration values by 500.

(Updated Marlin 2.0 bug-fix on 7/13/2020)


What options are enabled for the Ender 3?

  • Junction Deviation
  • S-Curve Acceleration
  • Thermal Runaway
  • Baby-stepping Z Axis
  • Linear Advance
  • Auto Bed Leveling (Bi-Linear)
  • Setup for an EZABL style Capacitive Proximity probe (Offsets and firmware for EZABL probe mount)
  • Extra menu options for configuration
  • Latest bugfix-2.0.x as of 7/13/2020

Ender 5 Firmware BigTreeTech SKR Mini E3

We are also uploading our firmware for the Ender 5 running a BigTreeTech SKR Mini E3 1.2 board. It’s currently running great, and we are glad to upload this somewhere. It took quite awhile to find a good firmware that works well. The firmware I started with was from a Git hub page, but it was just simply outdated by several versions and the config files wouldn’t compile in the newest marlin. We are not running the ABL probe on our Ender 5 yet, as we are waiting on parts to arrive. There is only manual mesh bed leveling activated inside, and you will need VSCode to edit this firmware for your needs. If you have the older style Z Axis lead-screw and you install the stock marlin firmware from the BTT github, your prints will be 1/2 the height in the Z axis; therefore we have included the 400 steps/mm and 800 steps/mm firmware. If your Ender 5 shipped pre-December 2019 you likely have 400 steps/mm and anything newer will likely be 800 steps/mm.



What options are enabled for the Ender 5?

  • Junction Deviation
  • S-Curve Acceleration
  • Thermal Runaway
  • Baby-stepping Z Axis
  • Mesh Bed Leveling (Manual Mesh)
  • Extra menus for configuration
  • Latest bugfix-2.0.x as of 7/13/2020
0 0 vote
Article Rating
Subscribe
Notify of
guest

This site uses Akismet to reduce spam. Learn how your comment data is processed.

32 Comments
Oldest
Newest Most Voted
Inline Feedbacks
View all comments
Smit Bhagat

How do I disable the EZ ABL? Im new to this and my ender is stock except for the SKR Mini e3 v2, and I want to start tuning linear advance and other settings, but I do not have the EZ ABL and do not know how to disable it in VSCode? Pls help.

Smash

Could you please send me the version of firmware w/ it disabled? Very annoyed I couldn’t get this thing to build. Thank you for doing this BTW.

Sam Jones

Why no linear advance on ender 5? but enabled on ender 3?
(also pages that say they have comments do not display any comments..)

Meeseeks479

You are a God amongst noobs lol I have been trying to find a working firmware for a week since I suck and can’t compile one yet i ws struggling with the x axis not compensating but you did it thanks man

JeppeH

Hi. I can’t find the .Bin file to flash? Do i have to create one? If so,,, how?
Downloaded the Ender 5 800 step version.

Last edited 1 month ago by JeppeH
JeppeH

Thanks! But, i see now that it is for version 1.2. My bad, sorry. I guess it will not work for vers. 2.0?
Edit* I don´t know if a´m totally stupid, but i can´t see that folder that you mentioned 🙁

Last edited 1 month ago by JeppeH
JeppeH

Ok. It’s so strange,,, i can’t see this folder. All i see is this –
https://imgur.com/GIi0BDz

Jeff Schumacher

Can you please post a version for the BLT V3? I’m going nuts trying to figure this thing out. Thank you!

Jeffrey Schumacher

Sorry, totally forgot to add any useful info. It’s the Ender 3 (not pro), SKR Mini E3 V2.0, BLTouch 3.0. I have the microswiss hotend and direct drive, Gulfcoast Robotics heated bed, BTT TFT 35 touch screen. I don’t know if any of that makes a difference.

I tried working out the firmware, but when I turn the printer on the BLTouch turns red, extends the probe twice and then I get an error saying cannot enable BLTouch. It disables ABL and none of the testing inputs work (test, extend, retract, etc.).

Also, I signed up for the forum, but I’m not getting the emails to set my password and they aren’t in spam. I’ll check to make sure my email is correct, but that’s why on messaging in here.

Jeffrey Schumacher

Awesome, I appreciate it a TON! I’m wondering if my BLTouch is bad. I know it’s wired properly, and it turns on. I don’t get any “unknown command” errors when I press any of the ABL testing buttons, but nothing happens.

I’ve seen a few tutorials for the SKR mini V2 with the v3, so I think it’s probably compatible, but none of them worked for me.

Thanks again, you’re a real hero.

David96

Hallo,
 I have an Ender 5 without any mods exept the SKR Mini E3 V2.0. I have tried using the file above: Ender 5 Marlin 2.0 bugfix for BigTreeTech SKR Mini E3 1.2 NEW Z Axis 800 steps/mm But my z moter started getting realy hot and the steps in y were way to les about ¼ of what is needed and the x motor was making weird noises. I was trying to change the settings in the firmware but it did`t work.
Does someone know how to fix this?

C.J.

Thank you for this code. Will your EZ ABL version work with a BLTouch? I have been struggling with getting or making a working firmware for my machine. The BTT Github one does not work at all, I cant even set my z axis offset because for some reason the Z0 is more than 10mm high off the bed, even though it does probe correctly. and no my sensor is not mounted too low.

I complied my own following a guide, and it mostly works, but it is buggy and not right somehow. Menus are wierd, and homescreen doesnt read information in a useful way.

My machine is an Ender 3, SKR mini E3V2 and I am running an BLtouch 3.1.

Last edited 25 days ago by C.J.
Aaron

Could you please compile the firmware of me? I have an Ender 5 pro. New Leadscrew (800 steps/mm) no other mods. I have the SKR mini E3 v2.0 board. Thank you so much

Aaron

Sent. Also can you do manual mesh leveling please?

Mike

Hi, I was trying to sign up to your forums to post this but it never sends me the email 🙁

I am working on my Ender 5 firmware to install the e3 v2, tft35, bltouch3, and the BTT filament runout sensor. I wanted to see if you had firmware for this setup that I could use to basically compare to mine as I am still learning all of this (throw in learning the vscode program rather than arduino I used for my silent board and bltouch upgrades and I get a bit overwhelmed) and really don’t want to screw it up so I figured why not ask here as you have a lot of preconfigured items already. I have edited mine (4 times now – ugh don’t ask) but I don’t trust myself 😉 I did remove the z-stop switch also when I installed the bltouch so i grabbed the appropriate files from btt as a starting point.

32
0
Would love your thoughts, please comment.x
()
x